WirelessKeyView

WirelessKeyView v1.27
Copyright (c) 2006 - 2009 Nir Sofer
Web Site: http://www.nirsoft.net

Description

WirelessKeyView recovers all wireless network keys (WEP/WPA) stored in your computer by the 'Wireless Zero Configuration' service of Windows XP or by the 'WLAN AutoConfig' service of Windows Vista. It allows you to easily save all keys to text/html/xml file, or copy a single key to the clipboard.

License

This utility is released as freeware. You are allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package, without any modification !
Be aware that selling this utility as a part of a software package is not allowed !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Versions History

  • Version 1.27:
    • Fixed bug: In Vista, WPA-PSK keys in Ascii form displayed additional space character.
  • Version 1.26:
    • Fixed bug: In Vista, if WPA-PSK key contained 32 characters, the key was not displayed in Ascii form.
  • Version 1.25:
    • New and safer method to extract the wireless keys of the local machine: In previous versions, WirelessKeyView injected code into lsass.exe in order to grab the wireless keys from the system. In rare cases, this technique caused a crash inside lsass.exe process. Starting from this version, WirelessKeyView uses a new method that extract the wireless keys without any code injection.
  • Version 1.20:
    • WirelessKeyView now allows you to extract the wireless keys from external instance of Windows XP. (In Advanced Options)
  • Version 1.18:
    • You can now send the information to stdout by specifying an empty filename ("") in the command-line. (For example: WirelessKeyView.exe /stab "" >> c:\temp\keys.txt)
  • Version 1.17:
    • Fixed bug: WirelessKeyView failed to find the adapter name
    • Fixed bug: Bad color in HTML report
    • Fixed bug: The main window lost the focus when the user switched to another application and then returned back to WirelessKeyView.
  • Version 1.16 - Added support for saving as comma-delimited file.
  • Version 1.15 - Added support for deleting the wireless keys of old network adapters.
  • Version 1.13 - Under Vista, this utility now runs as admin automatically. You don't have to explicitly choose the "Run As Administrator" option.
  • Version 1.12 - The configuration is now saved to a file instead of the Registry.
  • Version 1.11 - Fixed 'Access Violation' problem under some wireless cards.
  • Version 1.10 - Added support for Windows Vista. (both 32-bit and x64 versions)
  • Version 1.00 - First release.

System Requirement

  • Windows XP with SP1 or greater.
  • You must login to windows with admin user.

Using WirelessKeyView

WirelessKeyView doesn't require any installation process or additional DLL files. Just copy the executable file (WirelessKeyView.exe) to any folder you like, and run it.
After you run it, the main window should displayed all WEP/WPA keys stored in your computer by Windows 'Wireless Zero Configuration' service. For WEP keys, the key is also displayed in Ascii form. Be aware that this utility can only reveal the network keys stored by Windows operating system. It cannot recover network keys stored by any other third-party software.

Notice About WPA-PSK Keys

When you type a WPA-PSK key in Windows XP, the characters that you type are automatically converted into a new binary key that contains 32 bytes (64 Hexadecimal digits). This binary key cannot instantly be converted back to the original key that you typed, but you can still use it for connecting the wireless network exactly like the original key. In this case, WirelessKeyView displays this binary key in the Hex key column, but it doesn't display the original key that you typed.
As opposed to Windows XP, Windows Vista doesn't convert the WPA-PSK Key that you type into a new binary key, but it simply keep the original key that you type. So under Windows Vista, the original WPA-PSK key that you typed is displayed in the Ascii key column.

Deleting Wireless Keys Of Old Network Adapters

Starting from version 1.15 of WirelessKeyView, you can delete wireless keys of old network adapters that are no longer plugged to your computer, by using the 'Delete Selected Items' option.
Be aware that this delete option only works for network adapters that are not active anymore. If your network adapter is active, use the standard user interface of Windows to delete the unwanted keys.

Command-Line Options

/external <Windows Directory> | Load the wireless keys from external instance of Windows XP.
/stext <Filename> | Save the list of all wireless keys into a regular text file.
/stab <Filename> | Save the list of all wireless keys into a tab-delimited text file.
/stabular <Filename> | Save the list of all wireless keys into a tabular text file.
/shtml <Filename> | Save the list of all wireless keys into HTML file (Horizontal).
/sverhtml <Filename> | Save the list of all wireless keys into HTML file (Vertical).
/sxml <Filename> | Save the list of all wireless keys to XML file.

Translating WirelessKeyView to other languages

In order to translate WirelessKeyView to other language, follow the instructions below:
  1. Run WirelessKeyView with /savelangfile parameter:
    WirelessKeyView.exe /savelangfile
    A file named WirelessKeyView_lng.ini will be created in the folder of WirelessKeyView utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run WirelessKeyView, and all translated strings will be loaded from the language file.
    If you want to run WirelessKeyView without the translation, simply rename the language file, or move it to another folder.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com